Try to add FUNDING.yml.
[dcpomatic.git] / wscript
1 #
2 #    Copyright (C) 2012-2019 Carl Hetherington <cth@carlh.net>
3 #
4 #    This file is part of DCP-o-matic.
5 #
6 #    DCP-o-matic is free software; you can redistribute it and/or modify
7 #    it under the terms of the GNU General Public License as published by
8 #    the Free Software Foundation; either version 2 of the License, or
9 #    (at your option) any later version.
10 #
11 #    DCP-o-matic is distributed in the hope that it will be useful,
12 #    but WITHOUT ANY WARRANTY; without even the implied warranty of
13 #    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
14 #    GNU General Public License for more details.
15 #
16 #    You should have received a copy of the GNU General Public License
17 #    along with DCP-o-matic.  If not, see <http://www.gnu.org/licenses/>.
18 #
19
20 from __future__ import print_function
21
22 import subprocess
23 import os
24 import shlex
25 import sys
26 import glob
27 import distutils
28 import distutils.spawn
29 try:
30     # python 2
31     from urllib import urlencode
32 except ImportError:
33     # python 3
34     from urllib.parse import urlencode
35 from waflib import Logs, Context
36
37 APPNAME = 'dcpomatic'
38
39 this_version = subprocess.Popen(shlex.split('git tag -l --points-at HEAD'), stdout=subprocess.PIPE).communicate()[0]
40 last_version = subprocess.Popen(shlex.split('git describe --tags --abbrev=0'), stdout=subprocess.PIPE).communicate()[0]
41
42 # Python 2/3 compatibility; I don't really understand what's going on here
43 if not isinstance(this_version, str):
44     this_version = this_version.decode('utf-8')
45 if not isinstance(last_version, str):
46     last_version = last_version.decode('utf-8')
47
48 if this_version == '':
49     VERSION = '%sdevel' % last_version[1:].strip()
50 else:
51     VERSION = this_version[1:].strip()
52
53 def options(opt):
54     opt.load('compiler_cxx')
55     opt.load('winres')
56
57     opt.add_option('--enable-debug',      action='store_true', default=False, help='build with debugging information and without optimisation')
58     opt.add_option('--disable-gui',       action='store_true', default=False, help='disable building of GUI tools')
59     opt.add_option('--disable-tests',     action='store_true', default=False, help='disable building of tests')
60     opt.add_option('--install-prefix',                         default=None,  help='prefix of where DCP-o-matic will be installed')
61     opt.add_option('--target-windows',    action='store_true', default=False, help='set up to do a cross-compile to make a Windows package')
62     opt.add_option('--static-dcpomatic',  action='store_true', default=False, help='link to components of DCP-o-matic statically')
63     opt.add_option('--static-boost',      action='store_true', default=False, help='link statically to Boost')
64     opt.add_option('--static-wxwidgets',  action='store_true', default=False, help='link statically to wxWidgets')
65     opt.add_option('--static-ffmpeg',     action='store_true', default=False, help='link statically to FFmpeg')
66     opt.add_option('--static-xmlpp',      action='store_true', default=False, help='link statically to libxml++')
67     opt.add_option('--static-xmlsec',     action='store_true', default=False, help='link statically to xmlsec')
68     opt.add_option('--static-ssh',        action='store_true', default=False, help='link statically to libssh')
69     opt.add_option('--static-cxml',       action='store_true', default=False, help='link statically to libcxml')
70     opt.add_option('--static-dcp',        action='store_true', default=False, help='link statically to libdcp')
71     opt.add_option('--static-sub',        action='store_true', default=False, help='link statically to libsub')
72     opt.add_option('--static-curl',       action='store_true', default=False, help='link statically to libcurl')
73     opt.add_option('--workaround-gssapi', action='store_true', default=False, help='link to gssapi_krb5')
74     opt.add_option('--force-cpp11',       action='store_true', default=False, help='force use of C++11')
75     opt.add_option('--variant',           help='build variant', choices=['swaroop'])
76
77 def configure(conf):
78     conf.load('compiler_cxx')
79     conf.load('clang_compilation_database', tooldir=['waf-tools'])
80     if conf.options.target_windows:
81         conf.load('winres')
82
83     # Save conf.options that we need elsewhere in conf.env
84     conf.env.DISABLE_GUI = conf.options.disable_gui
85     conf.env.DISABLE_TESTS = conf.options.disable_tests
86     conf.env.TARGET_WINDOWS = conf.options.target_windows
87     conf.env.TARGET_OSX = sys.platform == 'darwin'
88     conf.env.TARGET_LINUX = not conf.env.TARGET_WINDOWS and not conf.env.TARGET_OSX
89     conf.env.VERSION = VERSION
90     conf.env.DEBUG = conf.options.enable_debug
91     conf.env.STATIC_DCPOMATIC = conf.options.static_dcpomatic
92     if conf.options.install_prefix is None:
93         conf.env.INSTALL_PREFIX = conf.env.PREFIX
94     else:
95         conf.env.INSTALL_PREFIX = conf.options.install_prefix
96
97     # Common CXXFLAGS
98     conf.env.append_value('CXXFLAGS', ['-D__STDC_CONSTANT_MACROS',
99                                        '-D__STDC_LIMIT_MACROS',
100                                        '-D__STDC_FORMAT_MACROS',
101                                        '-msse',
102                                        '-fno-strict-aliasing',
103                                        '-Wall',
104                                        '-Wcast-align',
105                                        '-Wextra',
106                                        '-Wwrite-strings',
107                                        # Remove auto_ptr warnings from libxml++-2.6
108                                        '-Wno-deprecated-declarations',
109                                        '-Wno-ignored-qualifiers',
110                                        '-Wno-parentheses',
111                                        '-D_FILE_OFFSET_BITS=64'])
112
113     if conf.options.force_cpp11:
114         conf.env.append_value('CXXFLAGS', ['-std=c++11', '-DBOOST_NO_CXX11_SCOPED_ENUMS'])
115
116     gcc = conf.env['CC_VERSION']
117     if int(gcc[0]) >= 4 and int(gcc[1]) > 1:
118         conf.env.append_value('CXXFLAGS', ['-Wno-unused-result'])
119     have_c11 = int(gcc[0]) >= 4 and int(gcc[1]) >= 8 and int(gcc[2]) >= 1
120
121     if conf.options.enable_debug:
122         conf.env.append_value('CXXFLAGS', ['-g', '-DDCPOMATIC_DEBUG', '-fno-omit-frame-pointer'])
123     else:
124         conf.env.append_value('CXXFLAGS', '-O2')
125
126     if conf.options.variant is not None:
127         conf.env.VARIANT = conf.options.variant
128         conf.env.append_value('CXXFLAGS', '-DDCPOMATIC_VARIANT_%s' % conf.options.variant.upper())
129
130     #
131     # Windows/Linux/OS X specific
132     #
133
134     # Windows
135     if conf.env.TARGET_WINDOWS:
136         conf.env.append_value('CXXFLAGS', '-DDCPOMATIC_WINDOWS')
137         conf.env.append_value('CXXFLAGS', '-DWIN32_LEAN_AND_MEAN')
138         conf.env.append_value('CXXFLAGS', '-DBOOST_USE_WINDOWS_H')
139         conf.env.append_value('CXXFLAGS', '-DUNICODE')
140         conf.env.append_value('CXXFLAGS', '-DBOOST_THREAD_PROVIDES_GENERIC_SHARED_MUTEX_ON_WIN')
141         conf.env.append_value('CXXFLAGS', '-mfpmath=sse')
142         conf.env.append_value('CXXFLAGS', '-std=c++11')
143         wxrc = os.popen('wx-config --rescomp').read().split()[1:]
144         conf.env.append_value('WINRCFLAGS', wxrc)
145         if conf.options.enable_debug:
146             conf.env.append_value('CXXFLAGS', ['-mconsole'])
147             conf.env.append_value('LINKFLAGS', ['-mconsole'])
148         conf.check(lib='ws2_32', uselib_store='WINSOCK2', msg="Checking for library winsock2")
149         conf.check(lib='dbghelp', uselib_store='DBGHELP', msg="Checking for library dbghelp")
150         conf.check(lib='shlwapi', uselib_store='SHLWAPI', msg="Checking for library shlwapi")
151         conf.check(lib='mswsock', uselib_store='MSWSOCK', msg="Checking for library mswsock")
152         conf.check(lib='ole32', uselib_store='OLE32', msg="Checking for library ole32")
153         conf.check(lib='dsound', uselib_store='DSOUND', msg="Checking for library dsound")
154         conf.check(lib='winmm', uselib_store='WINMM', msg="Checking for library winmm")
155         conf.check(lib='ksuser', uselib_store='KSUSER', msg="Checking for library ksuser")
156         boost_lib_suffix = '-mt'
157         boost_thread = 'boost_thread_win32-mt'
158         conf.check_cxx(fragment="""
159                                #include <boost/locale.hpp>\n
160                                int main() { std::locale::global (boost::locale::generator().generate ("")); }\n
161                                """,
162                                msg='Checking for boost locale library',
163                                libpath='/usr/local/lib',
164                                lib=['boost_locale%s' % boost_lib_suffix, 'boost_system%s' % boost_lib_suffix],
165                                uselib_store='BOOST_LOCALE')
166
167     # POSIX
168     if conf.env.TARGET_LINUX or conf.env.TARGET_OSX:
169         conf.env.append_value('CXXFLAGS', '-DDCPOMATIC_POSIX')
170         boost_lib_suffix = ''
171         boost_thread = 'boost_thread'
172         conf.env.append_value('LINKFLAGS', '-pthread')
173
174     # Linux
175     if conf.env.TARGET_LINUX:
176         conf.env.append_value('CXXFLAGS', '-mfpmath=sse')
177         conf.env.append_value('CXXFLAGS', '-DLINUX_LOCALE_PREFIX="%s/share/locale"' % conf.env['INSTALL_PREFIX'])
178         conf.env.append_value('CXXFLAGS', '-DLINUX_SHARE_PREFIX="%s/share/dcpomatic2"' % conf.env['INSTALL_PREFIX'])
179         conf.env.append_value('CXXFLAGS', '-DDCPOMATIC_LINUX')
180         conf.env.append_value('CXXFLAGS', ['-Wlogical-op', '-Wno-deprecated-copy'])
181         if not conf.env.DISABLE_GUI:
182             conf.check_cfg(package='gtk+-2.0', args='--cflags --libs', uselib_store='GTK', mandatory=True)
183
184     # OSX
185     if conf.env.TARGET_OSX:
186         conf.env.append_value('CXXFLAGS', ['-DDCPOMATIC_OSX', '-Wno-unused-function', '-Wno-unused-parameter', '-Wno-unused-local-typedef', '-Wno-potentially-evaluated-expression'])
187         conf.env.append_value('LINKFLAGS', '-headerpad_max_install_names')
188     else:
189         # Avoid the endless warnings about _t uninitialized in optional<>
190         conf.env.append_value('CXXFLAGS', '-Wno-maybe-uninitialized')
191
192     #
193     # Dependencies.
194     #
195
196     # It should be possible to use check_cfg for both dynamic and static linking, but
197     # e.g. pkg-config --libs --static foo returns some libraries that should be statically
198     # linked and others that should be dynamic.  This doesn't work too well with waf
199     # as it wants them separate.
200
201     # libcurl
202     if conf.options.static_curl:
203         conf.env.STLIB_CURL = ['curl']
204         conf.env.LIB_CURL = ['ssh2', 'idn']
205     else:
206         conf.check_cfg(package='libcurl', args='--cflags --libs', atleast_version='7.19.1', uselib_store='CURL', mandatory=True)
207
208     # libicu
209     if conf.check_cfg(package='icu-i18n', args='--cflags --libs', uselib_store='ICU', mandatory=False) is None:
210         if conf.check_cfg(package='icu', args='--cflags --libs', uselib_store='ICU', mandatory=False) is None:
211             conf.check_cxx(fragment="""
212                             #include <unicode/ucsdet.h>
213                             int main(void) {
214                                 UErrorCode status = U_ZERO_ERROR;
215                                 UCharsetDetector* detector = ucsdet_open (&status);
216                                 return 0; }\n
217                             """,
218                        mandatory=True,
219                        msg='Checking for libicu',
220                        okmsg='yes',
221                        libpath=['/usr/local/lib', '/usr/lib', '/usr/lib/x86_64-linux-gnu'],
222                        lib=['icuio', 'icui18n', 'icudata', 'icuuc'],
223                        uselib_store='ICU')
224
225     # libsamplerate
226     conf.check_cfg(package='samplerate', args='--cflags --libs', uselib_store='SAMPLERATE', mandatory=True)
227
228     # glib
229     conf.check_cfg(package='glib-2.0', args='--cflags --libs', uselib_store='GLIB', mandatory=True)
230
231     # libzip
232     conf.check_cfg(package='libzip', args='--cflags --libs', uselib_store='ZIP', mandatory=True)
233     conf.check_cxx(fragment="""
234                             #include <zip.h>
235                             int main() { zip_source_t* foo; }
236                             """,
237                    mandatory=False,
238                    msg="Checking for zip_source_t",
239                    uselib="ZIP",
240                    define_name='DCPOMATIC_HAVE_ZIP_SOURCE_T'
241                    )
242
243     # fontconfig
244     conf.check_cfg(package='fontconfig', args='--cflags --libs', uselib_store='FONTCONFIG', mandatory=True)
245
246     # pangomm
247     conf.check_cfg(package='pangomm-1.4', args='--cflags --libs', uselib_store='PANGOMM', mandatory=True)
248
249     # cairomm
250     conf.check_cfg(package='cairomm-1.0', args='--cflags --libs', uselib_store='CAIROMM', mandatory=True)
251
252     test_cxxflags = ''
253     if have_c11:
254         test_cxxflags = '-std=c++11'
255
256     # See if we have Cairo::ImageSurface::format_stride_for_width; Centos 5 does not
257     conf.check_cxx(fragment="""
258                             #include <cairomm/cairomm.h>
259                             int main(void) {
260                                 Cairo::ImageSurface::format_stride_for_width (Cairo::FORMAT_ARGB32, 1024);\n
261                                 return 0; }\n
262                             """,
263                        mandatory=False,
264                        cxxflags=test_cxxflags,
265                        msg='Checking for format_stride_for_width',
266                        okmsg='yes',
267                        includes=conf.env['INCLUDES_CAIROMM'],
268                        uselib='CAIROMM',
269                        define_name='DCPOMATIC_HAVE_FORMAT_STRIDE_FOR_WIDTH')
270
271     # See if we have Pango::Layout::show_in_cairo_context; Centos 5 does not
272     conf.check_cxx(fragment="""
273                             #include <pangomm.h>
274                             int main(void) {
275                                 Cairo::RefPtr<Cairo::Context> context;
276                                 Glib::RefPtr<Pango::Layout> layout;
277                                 layout->show_in_cairo_context (context);
278                                 return 0; }\n
279                             """,
280                        mandatory=False,
281                        msg='Checking for show_in_cairo_context',
282                        cxxflags=test_cxxflags,
283                        okmsg='yes',
284                        includes=conf.env['INCLUDES_PANGOMM'],
285                        uselib='PANGOMM',
286                        define_name='DCPOMATIC_HAVE_SHOW_IN_CAIRO_CONTEXT')
287
288
289     # libcxml
290     if conf.options.static_cxml:
291         conf.check_cfg(package='libcxml', atleast_version='0.16.0', args='--cflags', uselib_store='CXML', mandatory=True)
292         conf.env.STLIB_CXML = ['cxml']
293     else:
294         conf.check_cfg(package='libcxml', atleast_version='0.16.0', args='--cflags --libs', uselib_store='CXML', mandatory=True)
295
296     # libssh
297     if conf.options.static_ssh:
298         conf.env.STLIB_SSH = ['ssh']
299         if conf.options.workaround_gssapi:
300             conf.env.LIB_SSH = ['gssapi_krb5']
301     else:
302         conf.check_cc(fragment="""
303                                #include <libssh/libssh.h>\n
304                                int main () {\n
305                                ssh_session s = ssh_new ();\n
306                                return 0;\n
307                                }
308                                """,
309                       msg='Checking for library libssh',
310                       mandatory=True,
311                       lib='ssh',
312                       uselib_store='SSH')
313
314     # libdcp
315     if conf.options.static_dcp:
316         conf.check_cfg(package='libdcp-1.0', atleast_version='1.6.14', args='--cflags', uselib_store='DCP', mandatory=True)
317         conf.env.DEFINES_DCP = [f.replace('\\', '') for f in conf.env.DEFINES_DCP]
318         conf.env.STLIB_DCP = ['dcp-1.0', 'asdcp-cth', 'kumu-cth', 'openjp2']
319         conf.env.LIB_DCP = ['glibmm-2.4', 'ssl', 'crypto', 'bz2', 'xslt']
320     else:
321         conf.check_cfg(package='libdcp-1.0', atleast_version='1.6.14', args='--cflags --libs', uselib_store='DCP', mandatory=True)
322         conf.env.DEFINES_DCP = [f.replace('\\', '') for f in conf.env.DEFINES_DCP]
323
324     # libsub
325     if conf.options.static_sub:
326         conf.check_cfg(package='libsub-1.0', atleast_version='1.4.15', args='--cflags', uselib_store='SUB', mandatory=True)
327         conf.env.DEFINES_SUB = [f.replace('\\', '') for f in conf.env.DEFINES_SUB]
328         conf.env.STLIB_SUB = ['sub-1.0']
329     else:
330         conf.check_cfg(package='libsub-1.0', atleast_version='1.4.15', args='--cflags --libs', uselib_store='SUB', mandatory=True)
331         conf.env.DEFINES_SUB = [f.replace('\\', '') for f in conf.env.DEFINES_SUB]
332
333     # libxml++
334     if conf.options.static_xmlpp:
335         conf.env.STLIB_XMLPP = ['xml++-2.6']
336         conf.env.LIB_XMLPP = ['xml2']
337     else:
338         conf.check_cfg(package='libxml++-2.6', args='--cflags --libs', uselib_store='XMLPP', mandatory=True)
339
340     # libxmlsec
341     if conf.options.static_xmlsec:
342         if conf.check_cxx(lib='xmlsec1-openssl', mandatory=False):
343             conf.env.STLIB_XMLSEC = ['xmlsec1-openssl', 'xmlsec1']
344         else:
345             conf.env.STLIB_XMLSEC = ['xmlsec1']
346     else:
347         conf.env.LIB_XMLSEC = ['xmlsec1-openssl', 'xmlsec1']
348
349     # nettle
350     conf.check_cfg(package="nettle", args='--cflags --libs', uselib_store='NETTLE', mandatory=True)
351
352     # libpng
353     conf.check_cfg(package='libpng', args='--cflags --libs', uselib_store='PNG', mandatory=True)
354
355     # FFmpeg
356     if conf.options.static_ffmpeg:
357         names = ['avformat', 'avfilter', 'avcodec', 'avutil', 'swscale', 'postproc', 'swresample']
358         for name in names:
359             static = subprocess.Popen(shlex.split('pkg-config --static --libs lib%s' % name), stdout=subprocess.PIPE).communicate()[0].decode('utf-8')
360             libs = []
361             stlibs = []
362             include = []
363             libpath = []
364             for s in static.split():
365                 if s.startswith('-L'):
366                     libpath.append(s[2:])
367                 elif s.startswith('-I'):
368                     include.append(s[2:])
369                 elif s.startswith('-l'):
370                     if s[2:] not in names:
371                         libs.append(s[2:])
372                     else:
373                         stlibs.append(s[2:])
374
375             conf.env['LIB_%s' % name.upper()] = libs
376             conf.env['STLIB_%s' % name.upper()] = stlibs
377             conf.env['INCLUDES_%s' % name.upper()] = include
378             conf.env['LIBPATH_%s' % name.upper()] = libpath
379     else:
380         conf.check_cfg(package='libavformat', args='--cflags --libs', uselib_store='AVFORMAT', mandatory=True)
381         conf.check_cfg(package='libavfilter', args='--cflags --libs', uselib_store='AVFILTER', mandatory=True)
382         conf.check_cfg(package='libavcodec', args='--cflags --libs', uselib_store='AVCODEC', mandatory=True)
383         conf.check_cfg(package='libavutil', args='--cflags --libs', uselib_store='AVUTIL', mandatory=True)
384         conf.check_cfg(package='libswscale', args='--cflags --libs', uselib_store='SWSCALE', mandatory=True)
385         conf.check_cfg(package='libpostproc', args='--cflags --libs', uselib_store='POSTPROC', mandatory=True)
386         conf.check_cfg(package='libswresample', args='--cflags --libs', uselib_store='SWRESAMPLE', mandatory=True)
387
388     # Check to see if we have our version of FFmpeg that allows us to get at EBUR128 results
389     conf.check_cxx(fragment="""
390                             extern "C" {\n
391                             #include <libavfilter/f_ebur128.h>\n
392                             }\n
393                             int main () { av_ebur128_get_true_peaks (0); }\n
394                             """,
395                    msg='Checking for EBUR128-patched FFmpeg',
396                    uselib='AVCODEC AVFILTER',
397                    define_name='DCPOMATIC_HAVE_EBUR128_PATCHED_FFMPEG',
398                    mandatory=False)
399
400     # Check to see if we have our AVSubtitleRect has a pict member
401     # Older versions (e.g. that shipped with Ubuntu 16.04) do
402     conf.check_cxx(fragment="""
403                             extern "C" {\n
404                             #include <libavcodec/avcodec.h>\n
405                             }\n
406                             int main () { AVSubtitleRect r; r.pict; }\n
407                             """,
408                    msg='Checking for AVSubtitleRect::pict',
409                    cxxflags='-Wno-unused-result -Wno-unused-value -Wdeprecated-declarations -Werror',
410                    uselib='AVCODEC',
411                    define_name='DCPOMATIC_HAVE_AVSUBTITLERECT_PICT',
412                    mandatory=False)
413
414     # Check to see if we have our AVComponentDescriptor has a depth_minus1 member
415     # Older versions (e.g. that shipped with Ubuntu 16.04) do
416     conf.check_cxx(fragment="""
417                             extern "C" {\n
418                             #include <libavutil/pixdesc.h>\n
419                             }\n
420                             int main () { AVComponentDescriptor d; d.depth_minus1; }\n
421                             """,
422                    msg='Checking for AVComponentDescriptor::depth_minus1',
423                    cxxflags='-Wno-unused-result -Wno-unused-value -Wdeprecated-declarations -Werror',
424                    uselib='AVUTIL',
425                    define_name='DCPOMATIC_HAVE_AVCOMPONENTDESCRIPTOR_DEPTH_MINUS1',
426                    mandatory=False)
427
428     # Hack: the previous two check_cxx calls end up copying their (necessary) cxxflags
429     # to these variables.  We don't want to use these for the actual build, so clean them out.
430     conf.env['CXXFLAGS_AVCODEC'] = []
431     conf.env['CXXFLAGS_AVUTIL'] = []
432
433     # Boost
434     if conf.options.static_boost:
435         conf.env.STLIB_BOOST_THREAD = ['boost_thread']
436         conf.env.STLIB_BOOST_FILESYSTEM = ['boost_filesystem%s' % boost_lib_suffix]
437         conf.env.STLIB_BOOST_DATETIME = ['boost_date_time%s' % boost_lib_suffix, 'boost_system%s' % boost_lib_suffix]
438         conf.env.STLIB_BOOST_SIGNALS2 = ['boost_signals2']
439         conf.env.STLIB_BOOST_SYSTEM = ['boost_system']
440         conf.env.STLIB_BOOST_REGEX = ['boost_regex']
441     else:
442         conf.check_cxx(fragment="""
443                             #include <boost/version.hpp>\n
444                             #if BOOST_VERSION < 104500\n
445                             #error boost too old\n
446                             #endif\n
447                             int main(void) { return 0; }\n
448                             """,
449                        mandatory=True,
450                        msg='Checking for boost library >= 1.45',
451                        okmsg='yes',
452                        errmsg='too old\nPlease install boost version 1.45 or higher.')
453
454         conf.check_cxx(fragment="""
455                             #include <boost/thread.hpp>\n
456                             int main() { boost::thread t (); }\n
457                             """,
458                        msg='Checking for boost threading library',
459                        libpath='/usr/local/lib',
460                        lib=[boost_thread, 'boost_system%s' % boost_lib_suffix],
461                        uselib_store='BOOST_THREAD')
462
463         conf.check_cxx(fragment="""
464                             #include <boost/filesystem.hpp>\n
465                             int main() { boost::filesystem::copy_file ("a", "b"); }\n
466                             """,
467                        msg='Checking for boost filesystem library',
468                        libpath='/usr/local/lib',
469                        lib=['boost_filesystem%s' % boost_lib_suffix, 'boost_system%s' % boost_lib_suffix],
470                        uselib_store='BOOST_FILESYSTEM')
471
472         conf.check_cxx(fragment="""
473                             #include <boost/date_time.hpp>\n
474                             int main() { boost::gregorian::day_clock::local_day(); }\n
475                             """,
476                        msg='Checking for boost datetime library',
477                        libpath='/usr/local/lib',
478                        lib=['boost_date_time%s' % boost_lib_suffix, 'boost_system%s' % boost_lib_suffix],
479                        uselib_store='BOOST_DATETIME')
480
481         conf.check_cxx(fragment="""
482                             #include <boost/signals2.hpp>\n
483                             int main() { boost::signals2::signal<void (int)> x; }\n
484                             """,
485                        msg='Checking for boost signals2 library',
486                        uselib_store='BOOST_SIGNALS2')
487
488         conf.check_cxx(fragment="""
489                             #include <boost/regex.hpp>\n
490                             int main() { boost::regex re ("foo"); }\n
491                             """,
492                        msg='Checking for boost regex library',
493                        lib=['boost_regex%s' % boost_lib_suffix],
494                        uselib_store='BOOST_REGEX')
495
496     # libxml++ requires glibmm and versions of glibmm 2.45.31 and later
497     # must be built with -std=c++11 as they use c++11
498     # features and c++11 is not (yet) the default in gcc.
499     glibmm_version = conf.cmd_and_log(['pkg-config', '--modversion', 'glibmm-2.4'], output=Context.STDOUT, quiet=Context.BOTH)
500     s = glibmm_version.split('.')
501     v = (int(s[0]) << 16) | (int(s[1]) << 8) | int(s[2])
502     if v >= 0x022D1F:
503         conf.env.append_value('CXXFLAGS', '-std=c++11')
504
505     # Other stuff
506
507     conf.find_program('msgfmt', var='MSGFMT')
508     conf.check(header_name='valgrind/memcheck.h', mandatory=False)
509
510     datadir = conf.env.DATADIR
511     if not datadir:
512         datadir = os.path.join(conf.env.PREFIX, 'share')
513
514     conf.define('LOCALEDIR', os.path.join(datadir, 'locale'))
515     conf.define('DATADIR', datadir)
516
517     conf.recurse('src')
518     if not conf.env.DISABLE_TESTS:
519         conf.recurse('test')
520
521     Logs.pprint('YELLOW', '')
522     if conf.env.TARGET_WINDOWS:
523         Logs.pprint('YELLOW', '\t' + 'Target'.ljust(25) + ': Windows')
524     elif conf.env.TARGET_LINUX:
525         Logs.pprint('YELLOW', '\t' + 'Target'.ljust(25) + ': Linux')
526     elif conf.env.TARGET_OSX:
527         Logs.pprint('YELLOW', '\t' + 'Target'.ljust(25) + ': OS X')
528
529     def report(name, variable):
530         linkage = ''
531         if variable:
532             linkage = 'static'
533         else:
534             linkage = 'dynamic'
535         Logs.pprint('YELLOW', '\t%s: %s' % (name.ljust(25), linkage))
536
537     report('DCP-o-matic libraries', conf.options.static_dcpomatic)
538     report('Boost', conf.options.static_boost)
539     report('wxWidgets', conf.options.static_wxwidgets)
540     report('FFmpeg', conf.options.static_ffmpeg)
541     report('libxml++', conf.options.static_xmlpp)
542     report('xmlsec', conf.options.static_xmlsec)
543     report('libssh', conf.options.static_ssh)
544     report('libcxml', conf.options.static_cxml)
545     report('libdcp', conf.options.static_dcp)
546     report('libcurl', conf.options.static_curl)
547
548     Logs.pprint('YELLOW', '')
549
550 def download_supporters(can_fail):
551     r = os.system('curl -s -f https://dcpomatic.com/supporters.cc > src/wx/supporters.cc')
552     if (r >> 8) == 0:
553         r = os.system('curl -s -f https://dcpomatic.com/subscribers.cc > src/wx/subscribers.cc')
554     if (r >> 8) != 0:
555         if can_fail:
556             raise Exception("Could not download supporters lists (%d)" % (r >> 8))
557         else:
558             f = open('src/wx/supporters.cc', 'w')
559             print('supported_by.Add(wxT("Debug build - no supporters lists available"));', file=f)
560             f.close()
561             f = open('src/wx/subscribers.cc', 'w')
562             print('subscribers.Add(wxT("Debug build - no subscribers lists available"));', file=f)
563             f.close()
564
565 def build(bld):
566     create_version_cc(VERSION, bld.env.CXXFLAGS)
567     download_supporters(not bld.env.DEBUG)
568
569     bld.recurse('src')
570     bld.recurse('graphics')
571
572     if not bld.env.DISABLE_TESTS:
573         bld.recurse('test')
574     if bld.env.TARGET_WINDOWS:
575         bld.recurse('platform/windows')
576     if bld.env.TARGET_LINUX:
577         bld.recurse('platform/linux')
578     if bld.env.TARGET_OSX:
579         bld.recurse('platform/osx')
580
581     if not bld.env.TARGET_WINDOWS:
582         bld.install_files('${PREFIX}/share/dcpomatic2', 'fonts/LiberationSans-Regular.ttf')
583         bld.install_files('${PREFIX}/share/dcpomatic2', 'fonts/LiberationSans-Italic.ttf')
584         bld.install_files('${PREFIX}/share/dcpomatic2', 'fonts/LiberationSans-Bold.ttf')
585
586     bld.add_post_fun(post)
587
588 def git_revision():
589     if not os.path.exists('.git'):
590         return None
591
592     cmd = "LANG= git log --abbrev HEAD^..HEAD ."
593     output = subprocess.Popen(cmd, shell=True, stderr=subprocess.STDOUT, stdout=subprocess.PIPE).communicate()[0].splitlines()
594     if len(output) == 0:
595         return None
596     o = output[0].decode('utf-8')
597     return o.replace("commit ", "")[0:10]
598
599 def dist(ctx):
600     r = git_revision()
601     if r is not None:
602         f = open('.git_revision', 'w')
603         print(r, file=f)
604         f.close()
605
606     ctx.excl = """
607                TODO core *~ src/wx/*~ src/lib/*~ builds/*~ doc/manual/*~ src/tools/*~ *.pyc .waf* build .git
608                deps alignment hacks sync *.tar.bz2 *.exe .lock* *build-windows doc/manual/pdf doc/manual/html
609                GRSYMS GRTAGS GSYMS GTAGS compile_commands.json
610                """
611
612 def create_version_cc(version, cxx_flags):
613     commit = git_revision()
614     if commit is None and os.path.exists('.git_revision'):
615         f = open('.git_revision', 'r')
616         commit = f.readline().strip()
617
618     if commit is None:
619         commit = 'release'
620
621     try:
622         text =  '#include "version.h"\n'
623         text += 'char const * dcpomatic_git_commit = \"%s\";\n' % commit
624         text += 'char const * dcpomatic_version = \"%s\";\n' % version
625
626         t = ''
627         for f in cxx_flags:
628             f = f.replace('"', '\\"')
629             t += f + ' '
630         text += 'char const * dcpomatic_cxx_flags = \"%s\";\n' % t[:-1]
631
632         print('Writing version information to src/lib/version.cc')
633         o = open('src/lib/version.cc', 'w')
634         o.write(text)
635         o.close()
636     except IOError:
637         print('Could not open src/lib/version.cc for writing\n')
638         sys.exit(-1)
639
640 def post(ctx):
641     if ctx.cmd == 'install' and ctx.env.TARGET_LINUX:
642         ctx.exec_command('/sbin/ldconfig')
643         # I can't find anything which tells me where things have been installed to,
644         # so here's some nasty hacks to guess.
645         debian = os.path.join(ctx.out_dir, '../debian/dcpomatic/usr/bin/dcpomatic2_uuid')
646         prefix = os.path.join(ctx.env['INSTALL_PREFIX'], 'bin/dcpomatic2_uuid')
647         if os.path.exists(debian):
648             os.chmod(debian, 0o4755)
649         if os.path.exists(prefix):
650             os.chmod(prefix, 0o4755)
651
652 def pot(bld):
653     bld.recurse('src')
654
655 def pot_merge(bld):
656     bld.recurse('src')
657
658 def tags(bld):
659     os.system('etags src/lib/*.cc src/lib/*.h src/wx/*.cc src/wx/*.h src/tools/*.cc')
660
661 def cppcheck(bld):
662     os.system('cppcheck --enable=all --quiet .')