Add Ubuntu 19.04 deps.
authorCarl Hetherington <cth@carlh.net>
Sat, 6 Apr 2019 21:47:07 +0000 (22:47 +0100)
committerCarl Hetherington <cth@carlh.net>
Sat, 6 Apr 2019 21:47:07 +0000 (22:47 +0100)
cscript

diff --git a/cscript b/cscript
index 4de388b..428fddc 100644 (file)
--- a/cscript
+++ b/cscript
@@ -37,6 +37,8 @@ deb_build_depends['18.04'] = copy.deepcopy(deb_build_depends_base)
 deb_build_depends['18.04'].extend(['libssh-dev'])
 deb_build_depends['18.10'] = copy.deepcopy(deb_build_depends_base)
 deb_build_depends['18.10'].extend(['libssh-dev'])
+deb_build_depends['19.04'] = copy.deepcopy(deb_build_depends_base)
+deb_build_depends['19.04'].extend(['libssh-dev'])
 deb_build_depends['7'] = copy.deepcopy(deb_build_depends_base)
 deb_build_depends['7'].extend(['libssh-dev'])
 deb_build_depends['8'] = copy.deepcopy(deb_build_depends_base)
@@ -115,6 +117,23 @@ deb_depends['18.10'].extend(['libboost-filesystem1.65.1',
                              'libcurl4',
                              'libpulse0'])
 
+deb_depends['19.04'] = copy.deepcopy(deb_depends_base)
+deb_depends['19.04'].extend(['libboost-filesystem1.67.0',
+                             'libboost-thread1.67.0',
+                             'libboost-regex1.67.0',
+                             'libboost-date-time1.67.0',
+                             'libcairomm-1.0-1v5',
+                             'libpangomm-1.4-1v5',
+                             'libxml++2.6-2v5',
+                             'libzip5',
+                             'libwxgtk3.0-0v5',
+                             'libicu63',
+                             'libnettle6',
+                             'libssh-4',
+                             'libx264-155',
+                             'libcurl4',
+                             'libpulse0'])
+
 deb_depends['7'] = copy.deepcopy(deb_depends_base)
 deb_depends['7'].extend(['libboost-filesystem1.49.0',
                          'libboost-thread1.49.0',