fixed build error with position of variable declaration after patch 856
[openjpeg.git] / config.nix
1 MAJOR = 1
2 MINOR = 4
3 BUILD = 0
4
5 prefix=/usr/local
6 CC = gcc
7 AR = ar
8 #
9 #Set this to no if you do no want to compile/install shared libs.
10 ENABLE_SHARED = yes
11 #
12 #Set to yes if you BOTH have the library AND the header
13 #Set to no if a file is missing or you hate it.
14 #Either lcms or lcms2 : not both
15 #==== HAVE YOU CREATED opj_config.h FROM opj_config.h.in.user ? ====
16 #==== SHOULD BE IN SYNC WITH opj_config.h ====
17 WITH_LCMS1 = no
18 WITH_LCMS2 = no
19 WITH_PNG = no
20 WITH_TIFF = no
21 #
22 # Set to yes if you want compile/install 
23 #    jpwl libraries/binaries
24 WITH_JPWL = no
25 #
26 #Set to yes if you have doxygen installed
27 #Set to no if doxygen is missing.
28 HAS_DOXYGEN = no
29
30 #Check whether these paths are correct; change them appropiatly.
31 LCMS1_INCLUDE = -I/usr/include
32 LCMS2_INCLUDE = -I/usr/include
33 PNG_INCLUDE = -I/usr/include
34 TIFF_INCLUDE = -I/usr/include
35
36 LCMS1_LIB = -L/usr/lib -llcms
37 LCMS2_LIB = -L/usr/lib -llcms2
38 PNG_LIB = -L/usr/lib -lpng -lz
39 #tiff with jpeg/jbig support?
40 JBIG_LIB = -ljbig
41 JBIG85_LIB = -ljbig85
42 JPEG_LIB = -ljpeg
43 TIFF_LIB = -L/usr/lib -ltiff $(JPEG_LIB) $(JBIG_LIB) $(JBIG85_LIB)