M configure
[openjpeg.git] / config.nix
1 MAJOR = 1
2 MINOR = 4
3 BUILD = 0
4
5 JP3D_MAJOR = 1
6 JP3D_MINOR = 3
7 JP3D_BUILD = 0
8
9 prefix=/usr/local
10 CC = gcc
11 LDCONFIG = /sbin/ldconfig
12 #
13 #Set this to no if you do no want to compile/install shared libs.
14 ENABLE_SHARED = yes
15 #
16 #Set to yes if you BOTH have the library AND the header
17 #Set to no if a file is missing or you hate it.
18 #Either lcms or lcms2 : not both
19 #==== HAVE YOU CREATED opj_config.h FROM opj_config.h.in.user ? ====
20 #==== SHOULD BE IN SYNC WITH opj_config.h ====
21 WITH_LCMS1 = no
22 WITH_LCMS2 = no
23 WITH_PNG = no
24 WITH_TIFF = no
25 #
26 # Set to yes if you want compile/install 
27 #    jpwl libraries/binaries
28 #    jp3d libraries/binaries
29 WITH_JPWL = no
30 WITH_JP3D = no
31 #
32 #Set to yes if you have doxygen installed
33 #Set to no if doxygen is missing.
34 HAS_DOXYGEN = no
35
36 #Check whether these paths are correct; change them appropiatly.
37 LCMS1_INCLUDE = -I/usr/include
38 LCMS2_INCLUDE = -I/usr/include
39 PNG_INCLUDE = -I/usr/include
40 TIFF_INCLUDE = -I/usr/include
41
42 LCMS1_LIB = -L/usr/lib -llcms -lm
43 LCMS2_LIB = -L/usr/lib -llcms2 -lm
44 PNG_LIB = -L/usr/lib -lpng -lz -lm
45 TIFF_LIB = -L/usr/lib -ltiff -lm