removed LCMS dependency in jp3d/libjp3dvm/CMakeLists.txt
[openjpeg.git] / config.nix
1 MAJOR = 1
2 MINOR = 4
3 BUILD = 0
4
5 JP3D_MAJOR = 1
6 JP3D_MINOR = 3
7 JP3D_BUILD = 0
8
9 prefix=/usr/local
10 CC = gcc
11 LDCONFIG = /sbin/ldconfig
12 AR = ar
13 #
14 #Set this to no if you do no want to compile/install shared libs.
15 ENABLE_SHARED = yes
16 #
17 #Set to yes if you BOTH have the library AND the header
18 #Set to no if a file is missing or you hate it.
19 #Either lcms or lcms2 : not both
20 #==== HAVE YOU CREATED opj_config.h FROM opj_config.h.in.user ? ====
21 #==== SHOULD BE IN SYNC WITH opj_config.h ====
22 WITH_LCMS1 = no
23 WITH_LCMS2 = no
24 WITH_PNG = no
25 WITH_TIFF = no
26 #
27 # Set to yes if you want compile/install 
28 #    jpwl libraries/binaries
29 #    jp3d libraries/binaries
30 WITH_JPWL = no
31 WITH_JP3D = no
32 #
33 #Set to yes if you have doxygen installed
34 #Set to no if doxygen is missing.
35 HAS_DOXYGEN = no
36
37 #Check whether these paths are correct; change them appropiatly.
38 LCMS1_INCLUDE = -I/usr/include
39 LCMS2_INCLUDE = -I/usr/include
40 PNG_INCLUDE = -I/usr/include
41 TIFF_INCLUDE = -I/usr/include
42
43 LCMS1_LIB = -L/usr/lib -llcms
44 LCMS2_LIB = -L/usr/lib -llcms2
45 PNG_LIB = -L/usr/lib -lpng -lz
46 #tiff with jpeg/jbig support?
47 JBIG_LIB = -ljbig
48 JBIG85_LIB = -ljbig85
49 JPEG_LIB = -ljpeg
50 TIFF_LIB = -L/usr/lib -ltiff $(JPEG_LIB) $(JBIG_LIB) $(JBIG85_LIB)