Added files to let people build openjpeg with configure tools ; Added makefiles to...
[openjpeg.git] / config.nix
1 MAJOR = 1
2 MINOR = 4
3 BUILD = 0
4
5 JP3D_MAJOR = 1
6 JP3D_MINOR = 3
7 JP3D_BUILD = 0
8
9 prefix=/usr/local
10 CC = gcc
11
12 #Set this to yes if you want to compile/install shared libs.
13 ENABLE_SHARED = no
14 #
15 #Set to yes if you BOTH have the library AND the header
16 #Set to no if a file is missing or you hate it.
17 #Either lcms or lcms2 : not both
18 #SHOULD BE IN SYNC WITH opj_config.h
19 WITH_LCMS1 = no
20 WITH_LCMS2 = no
21 WITH_PNG = no
22 WITH_TIFF = no
23
24 #Set to yes if you have doxygen installed
25 #Set to no if doxygen is missing.
26 HAS_DOXYGEN = yes
27
28 #Check whether these paths are correct; change them appropiatly.
29 LCMS1_INCLUDE = -I/usr/include
30 LCMS2_INCLUDE = -I/usr/include
31 PNG_INCLUDE = -I/usr/include
32 TIFF_INCLUDE = -I/usr/include
33
34 LCMS1_LIB = -L/usr/lib -llcms -lm
35 LCMS2_LIB = -L/usr/lib -llcms2 -lm
36 PNG_LIB = -L/usr/lib -lpng -lz -lm
37 TIFF_LIB = -L/usr/lib -ltiff -lm