-This line, and those below, will be ignored--
[openjpeg.git] / config.nix
1 MAJOR = 1
2 MINOR = 4
3 BUILD = 0
4
5 JP3D_MAJOR = 1
6 JP3D_MINOR = 3
7 JP3D_BUILD = 0
8
9 prefix=/usr/local/OPJ646
10 CC = gcc
11
12 #Set this to yes if you want to compile/install shared libs.
13 ENABLE_SHARED = yes
14 #
15 #Set to yes if you BOTH have the library AND the header
16 #Set to no if a file is missing or you hate it.
17 #Either lcms or lcms2 : not both
18 #==== HAVE YOU CREATED opj_config.h FROM opj_config.h.in.user ? ====
19 #==== SHOULD BE IN SYNC WITH opj_config.h ====
20 WITH_LCMS1 = no
21 WITH_LCMS2 = yes
22 WITH_PNG = yes
23 WITH_TIFF = yes
24 #
25 # Set to yes if you want compile/install 
26 #    jpwl libraries/binaries
27 #    jp3d libraries/binaries
28 WITH_JPWL = yes
29 WITH_JP3D = yes
30 #
31 #Set to yes if you have doxygen installed
32 #Set to no if doxygen is missing.
33 HAS_DOXYGEN = yes
34
35 #Check whether these paths are correct; change them appropiatly.
36 LCMS1_INCLUDE = -I/usr/include
37 LCMS2_INCLUDE = -I/usr/include
38 PNG_INCLUDE = -I/usr/include
39 TIFF_INCLUDE = -I/usr/include
40
41 LCMS1_LIB = -L/usr/lib -llcms -lm
42 LCMS2_LIB = -L/usr/lib -llcms2 -lm
43 PNG_LIB = -L/usr/lib -lpng -lz -lm
44 TIFF_LIB = -L/usr/lib -ltiff -lm