Support debian 11.
authorCarl Hetherington <cth@carlh.net>
Mon, 6 Sep 2021 22:45:59 +0000 (00:45 +0200)
committerCarl Hetherington <cth@carlh.net>
Sun, 12 Sep 2021 23:22:00 +0000 (01:22 +0200)
cscript

diff --git a/cscript b/cscript
index ee48309..db676c3 100644 (file)
--- a/cscript
+++ b/cscript
@@ -27,15 +27,19 @@ import json
 
 deb_build_depends = dict()
 
-deb_build_depends_base = ['debhelper', 'python', 'g++', 'pkg-config', 'libsndfile1-dev', 'libgtk2.0-dev', 'libx264-dev']
+deb_build_depends_base = ['debhelper', 'g++', 'pkg-config', 'libsndfile1-dev', 'libgtk2.0-dev', 'libx264-dev']
 
 for v in ['16.04', '18.04', '20.04', '20.10', '21.04']: 
     deb_build_depends[v] = copy.deepcopy(deb_build_depends_base)
-    deb_build_depends[v].extend(['libssh-dev'])
+    deb_build_depends[v].extend(['libssh-dev', 'python'])
 for v in ['9', '10']:
     deb_build_depends[v] = copy.deepcopy(deb_build_depends_base)
-    deb_build_depends[v].extend(['libssh-gcrypt-dev'])
+    deb_build_depends[v].extend(['libssh-gcrypt-dev', 'python'])
+for v in ['11']:
+    deb_build_depends[v] = copy.deepcopy(deb_build_depends_base)
+    deb_build_depends[v].extend(['libssh-gcrypt-dev', 'python3.9'])
 deb_build_depends['unstable'] = copy.deepcopy(deb_build_depends_base)
+deb_build_depends['unstable'].extend(['python'])
 
 deb_depends = dict()
 deb_depends_gui = dict()
@@ -182,6 +186,30 @@ deb_depends_gui['10'] = [ 'libwxgtk3.0-0v5',
                           'libasound2',
                           'libpulse0' ]
 
+deb_depends['11'] = copy.deepcopy(deb_depends_base)
+deb_depends['11'].extend(['libboost-filesystem1.74.0',
+                          'libboost-thread1.74.0',
+                          'libboost-regex1.74.0',
+                          'libboost-date-time1.74.0',
+                          'libxml++2.6-2v5',
+                          'libzip4',
+                          'libcairomm-1.0-1v5',
+                          'libpangomm-1.4-1v5',
+                          'libicu67',
+                          'libssh-4',
+                          'libssh-gcrypt-4',
+                          'libnettle8',
+                          'libx264-160',
+                          'libcurl4',
+                          'libxerces-c3.2',
+                          'libnanomsg5'])
+
+deb_depends_gui['11'] = [ 'libwxgtk3.0-gtk3-0v5',
+                          'libxcb-xfixes0',
+                          'libxcb-shape0',
+                          'libasound2',
+                          'libpulse0' ]
+
 deb_depends['unstable'] = copy.deepcopy(deb_depends_base)
 deb_depends['unstable'].extend(['libboost-filesystem1.67.0',
                                 'libboost-thread1.67.0',