Try to allow build on Ubuntu 20.04.
authorCarl Hetherington <cth@carlh.net>
Thu, 14 May 2020 20:09:06 +0000 (22:09 +0200)
committerCarl Hetherington <cth@carlh.net>
Thu, 14 May 2020 20:09:06 +0000 (22:09 +0200)
cscript

diff --git a/cscript b/cscript
index a17b3af..1addf43 100644 (file)
--- a/cscript
+++ b/cscript
@@ -37,6 +37,8 @@ deb_build_depends['19.04'] = copy.deepcopy(deb_build_depends_base)
 deb_build_depends['19.04'].extend(['libssh-dev'])
 deb_build_depends['19.10'] = copy.deepcopy(deb_build_depends_base)
 deb_build_depends['19.10'].extend(['libssh-dev'])
+deb_build_depends['20.04'] = copy.deepcopy(deb_build_depends_base)
+deb_build_depends['20.04'].extend(['libssh-dev'])
 deb_build_depends['7'] = copy.deepcopy(deb_build_depends_base)
 deb_build_depends['7'].extend(['libssh-dev'])
 deb_build_depends['8'] = copy.deepcopy(deb_build_depends_base)
@@ -119,6 +121,25 @@ deb_depends['19.10'].extend(['libboost-filesystem1.67.0',
                              'libcurl4',
                              'libpulse0'])
 
+deb_depends['20.04'] = copy.deepcopy(deb_depends_base)
+deb_depends['20.04'].extend(['libboost-filesystem1.71.0',
+                             'libboost-thread1.71.0',
+                             'libboost-regex1.71.0',
+                             'libboost-date-time1.71.0',
+                             'libcairomm-1.0-1v5',
+                             'libpangomm-1.4-1v5',
+                             'libxml++2.6-2v5',
+                             'libzip5',
+                             'libwxgtk3.0-gtk3-0v5',
+                             'libicu66',
+                             'libnettle7',
+                             'libssh-4',
+                             'libx264-155',
+                             'libcurl4',
+                             'libpulse0',
+                             'libxerces-c3.2',
+                             'libnanomsg5'])
+
 deb_depends['8'] = copy.deepcopy(deb_depends_base)
 deb_depends['8'].extend(['libboost-filesystem1.55.0',
                          'libboost-thread1.55.0',