Merge master; fix crash on new film.
[dcpomatic.git] / debian / rules
index 7f7da5530eddbb8d128f2ba9035454482dbe7844..17594701970869bd061c1f082cfdeb531c5607b0 100755 (executable)
@@ -14,7 +14,7 @@
 
 override_dh_auto_configure:
        LINKFLAGS=$(CDIST_LINKFLAGS) CXXFLAGS="$(CXXFLAGS) $(CDIST_CXXFLAGS)" PKG_CONFIG_PATH=$(CDIST_PKG_CONFIG_PATH) \
-                ./waf --nocache configure --prefix=/usr --static
+                ./waf --nocache configure --prefix=/usr --static --enable-debug
 
 override_dh_auto_build:
        ./waf --nocache build
@@ -22,3 +22,6 @@ override_dh_auto_build:
 override_dh_auto_install:
        ./waf --nocache install --destdir=debian/dcpomatic
 
+.PHONY: override_dh_strip
+override_dh_strip:
+       dh_strip --dbg-package=dvdomatic-dbg