Fix disk_writer perms in .deb files (#1994).
[dcpomatic.git] / debian / rules
index c45682033fa53335ec2c6607335210efdcca611c..2a2a536395abd19cffff1ab2523156a5b47fa7c4 100755 (executable)
@@ -38,8 +38,8 @@ override_dh_auto_install:
        mkdir -p debian/dcpomatic/usr/share/locale/ru/LC_MESSAGES/
        cp -a /usr/share/locale/ru/LC_MESSAGES/wxstd.mo debian/dcpomatic/usr/share/locale/ru/LC_MESSAGES/dcpomatic2-wxstd.mo
        cp -a $(CDIST_DIRECTORY)/src/openssl/apps/openssl debian/dcpomatic/usr/bin/dcpomatic2_openssl
-       mkdir -p debian/dcpomatic/usr/share/libdcp
-       cp -ar $(CDIST_DIRECTORY)/share/libdcp/xsd debian/dcpomatic/usr/share/libdcp
+       cp -a $(CDIST_DIRECTORY)/src/libdcp/build/tools/dcpverify debian/dcpomatic/usr/bin/dcpomatic2_verify
+       cp -ar $(CDIST_DIRECTORY)/share/libdcp debian/dcpomatic/usr/share
 
 .PHONY: override_dh_strip
 override_dh_strip:
@@ -49,5 +49,5 @@ override_dh_shlibdeps:
        dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info
 
 override_dh_fixperms:
-       dh_fixperms --exclude usr/bin/dcpomatic2_uuid
-       dh_fixperms --exclude usr/bin/dcpomatic2_disk_writer
+       dh_fixperms
+       chmod 4755 debian/dcpomatic/usr/bin/dcpomatic2_disk_writer