Use dcp::file_to_string().
[dcpomatic.git] / debian / rules
index 6a8c156f1e5d47b7abd8c968c40d53a9ff733f9c..aac2dacaa9892fd2f197d3250c28165c8814e7cb 100755 (executable)
@@ -38,6 +38,8 @@ override_dh_auto_install:
        mkdir -p debian/dcpomatic/usr/share/locale/ru/LC_MESSAGES/
        cp -a /usr/share/locale/ru/LC_MESSAGES/wxstd.mo debian/dcpomatic/usr/share/locale/ru/LC_MESSAGES/dcpomatic2-wxstd.mo
        cp -a $(CDIST_DIRECTORY)/src/openssl/apps/openssl debian/dcpomatic/usr/bin/dcpomatic2_openssl
+       cp -a $(CDIST_DIRECTORY)/src/libdcp/build/tools/dcpverify debian/dcpomatic/usr/bin/dcpomatic2_verify
+       cp -ar $(CDIST_DIRECTORY)/share/libdcp debian/dcpomatic/usr/share
 
 .PHONY: override_dh_strip
 override_dh_strip:
@@ -46,5 +48,3 @@ override_dh_strip:
 override_dh_shlibdeps:
        dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info
 
-override_dh_fixperms:
-       dh_fixperms --exclude usr/bin/dcpomatic2_uuid