Use dcp::file_to_string().
[dcpomatic.git] / debian / rules
index 887100128751af80adbec575c34f75af36533167..aac2dacaa9892fd2f197d3250c28165c8814e7cb 100755 (executable)
@@ -38,6 +38,7 @@ override_dh_auto_install:
        mkdir -p debian/dcpomatic/usr/share/locale/ru/LC_MESSAGES/
        cp -a /usr/share/locale/ru/LC_MESSAGES/wxstd.mo debian/dcpomatic/usr/share/locale/ru/LC_MESSAGES/dcpomatic2-wxstd.mo
        cp -a $(CDIST_DIRECTORY)/src/openssl/apps/openssl debian/dcpomatic/usr/bin/dcpomatic2_openssl
+       cp -a $(CDIST_DIRECTORY)/src/libdcp/build/tools/dcpverify debian/dcpomatic/usr/bin/dcpomatic2_verify
        cp -ar $(CDIST_DIRECTORY)/share/libdcp debian/dcpomatic/usr/share
 
 .PHONY: override_dh_strip
@@ -47,6 +48,3 @@ override_dh_strip:
 override_dh_shlibdeps:
        dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info
 
-override_dh_fixperms:
-       dh_fixperms --exclude usr/bin/dcpomatic2_uuid
-       dh_fixperms --exclude usr/bin/dcpomatic2_disk_writer