Missing library from test link list.
[dcpomatic.git] / debian / rules
index b41487f86806b42ce5a0d558b412624efa36f6a1..c45682033fa53335ec2c6607335210efdcca611c 100755 (executable)
@@ -22,22 +22,32 @@ override_dh_auto_build:
 override_dh_auto_install:
        ./waf install --destdir=debian/dcpomatic
        mkdir -p debian/dcpomatic/usr/share/locale/de/LC_MESSAGES/
-       cp -a $(CDIST_LOCALE_PREFIX)/de/LC_MESSAGES/wxstd.mo debian/dcpomatic/usr/share/locale/de/LC_MESSAGES/dcpomatic2-wxstd.mo
+       cp -a /usr/share/locale/de/LC_MESSAGES/wxstd.mo debian/dcpomatic/usr/share/locale/de/LC_MESSAGES/dcpomatic2-wxstd.mo
        mkdir -p debian/dcpomatic/usr/share/locale/es/LC_MESSAGES/
-       cp -a $(CDIST_LOCALE_PREFIX)/es/LC_MESSAGES/wxstd.mo debian/dcpomatic/usr/share/locale/es/LC_MESSAGES/dcpomatic2-wxstd.mo
+       cp -a /usr/share/locale/es/LC_MESSAGES/wxstd.mo debian/dcpomatic/usr/share/locale/es/LC_MESSAGES/dcpomatic2-wxstd.mo
        mkdir -p debian/dcpomatic/usr/share/locale/fr/LC_MESSAGES/
-       cp -a $(CDIST_LOCALE_PREFIX)/fr/LC_MESSAGES/wxstd.mo debian/dcpomatic/usr/share/locale/fr/LC_MESSAGES/dcpomatic2-wxstd.mo
+       cp -a /usr/share/locale/fr/LC_MESSAGES/wxstd.mo debian/dcpomatic/usr/share/locale/fr/LC_MESSAGES/dcpomatic2-wxstd.mo
        mkdir -p debian/dcpomatic/usr/share/locale/it/LC_MESSAGES/
-       cp -a $(CDIST_LOCALE_PREFIX)/it/LC_MESSAGES/wxstd.mo debian/dcpomatic/usr/share/locale/it/LC_MESSAGES/dcpomatic2-wxstd.mo
+       cp -a /usr/share/locale/it/LC_MESSAGES/wxstd.mo debian/dcpomatic/usr/share/locale/it/LC_MESSAGES/dcpomatic2-wxstd.mo
        mkdir -p debian/dcpomatic/usr/share/locale/sv/LC_MESSAGES/
-       cp -a $(CDIST_LOCALE_PREFIX)/sv/LC_MESSAGES/wxstd.mo debian/dcpomatic/usr/share/locale/sv/LC_MESSAGES/dcpomatic2-wxstd.mo
+       cp -a /usr/share/locale/sv/LC_MESSAGES/wxstd.mo debian/dcpomatic/usr/share/locale/sv/LC_MESSAGES/dcpomatic2-wxstd.mo
        mkdir -p debian/dcpomatic/usr/share/locale/nl/LC_MESSAGES/
-       cp -a $(CDIST_LOCALE_PREFIX)/nl/LC_MESSAGES/wxstd.mo debian/dcpomatic/usr/share/locale/nl/LC_MESSAGES/dcpomatic2-wxstd.mo
+       cp -a /usr/share/locale/nl/LC_MESSAGES/wxstd.mo debian/dcpomatic/usr/share/locale/nl/LC_MESSAGES/dcpomatic2-wxstd.mo
        mkdir -p debian/dcpomatic/usr/share/locale/pl/LC_MESSAGES/
-       cp -a $(CDIST_LOCALE_PREFIX)/pl/LC_MESSAGES/wxstd.mo debian/dcpomatic/usr/share/locale/pl/LC_MESSAGES/dcpomatic2-wxstd.mo
+       cp -a /usr/share/locale/pl/LC_MESSAGES/wxstd.mo debian/dcpomatic/usr/share/locale/pl/LC_MESSAGES/dcpomatic2-wxstd.mo
        mkdir -p debian/dcpomatic/usr/share/locale/ru/LC_MESSAGES/
-       cp -a $(CDIST_LOCALE_PREFIX)/ru/LC_MESSAGES/wxstd.mo debian/dcpomatic/usr/share/locale/ru/LC_MESSAGES/dcpomatic2-wxstd.mo
+       cp -a /usr/share/locale/ru/LC_MESSAGES/wxstd.mo debian/dcpomatic/usr/share/locale/ru/LC_MESSAGES/dcpomatic2-wxstd.mo
+       cp -a $(CDIST_DIRECTORY)/src/openssl/apps/openssl debian/dcpomatic/usr/bin/dcpomatic2_openssl
+       mkdir -p debian/dcpomatic/usr/share/libdcp
+       cp -ar $(CDIST_DIRECTORY)/share/libdcp/xsd debian/dcpomatic/usr/share/libdcp
 
 .PHONY: override_dh_strip
 override_dh_strip:
-       dh_strip
+       dh_strip $(CDIST_DEBUG_PACKAGE)
+
+override_dh_shlibdeps:
+       dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info
+
+override_dh_fixperms:
+       dh_fixperms --exclude usr/bin/dcpomatic2_uuid
+       dh_fixperms --exclude usr/bin/dcpomatic2_disk_writer