Move Film::make_kdms to the call sites.
[dcpomatic.git] / debian / rules
index c84a78453bf5a82bc33b9fa6fa98f4b0f8fe22dc..c45682033fa53335ec2c6607335210efdcca611c 100755 (executable)
@@ -37,6 +37,9 @@ override_dh_auto_install:
        cp -a /usr/share/locale/pl/LC_MESSAGES/wxstd.mo debian/dcpomatic/usr/share/locale/pl/LC_MESSAGES/dcpomatic2-wxstd.mo
        mkdir -p debian/dcpomatic/usr/share/locale/ru/LC_MESSAGES/
        cp -a /usr/share/locale/ru/LC_MESSAGES/wxstd.mo debian/dcpomatic/usr/share/locale/ru/LC_MESSAGES/dcpomatic2-wxstd.mo
+       cp -a $(CDIST_DIRECTORY)/src/openssl/apps/openssl debian/dcpomatic/usr/bin/dcpomatic2_openssl
+       mkdir -p debian/dcpomatic/usr/share/libdcp
+       cp -ar $(CDIST_DIRECTORY)/share/libdcp/xsd debian/dcpomatic/usr/share/libdcp
 
 .PHONY: override_dh_strip
 override_dh_strip:
@@ -47,3 +50,4 @@ override_dh_shlibdeps:
 
 override_dh_fixperms:
        dh_fixperms --exclude usr/bin/dcpomatic2_uuid
+       dh_fixperms --exclude usr/bin/dcpomatic2_disk_writer